В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vlad199411003
vlad199411003
21.07.2021 22:55 •  Информатика

напишите программу

Определить стоимость набора конфет, в который входят: "Красная шапочка" - X1 г, "Алые паруса" - X2 г, "Чародейка" - X3 г, если известна стоимость этих конфет за 1 кг(S1, S2, S3 - все переменные - real). Вывод стоимости набора конфет - два знака после запятой.

Sample Input:

100 200 250 150 200 100
Sample Output:

80.00​

Ответ:
Ожзвэ
Ожзвэ
18.02.2021 00:16

var x1, x2, x3, s1, s2, s3: real;

begin

read (x1, x2, x3, s1, s2, s3);

writeln(((x1 * s1 + x2 * s2 + x3 * s3) / 1000):0:2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?