В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Crazy2daisy
Crazy2daisy
05.08.2021 19:11 •  Информатика

Сколько чисел в 10 массивах превосходит его среднее арефмитическое


Сколько чисел в 10 массивах превосходит его среднее арефмитическое

Ответ:
taske047Ataske
taske047Ataske
15.02.2021 20:03

program average;

const n=10;

var avg:real; //среднее ариф.

   count:integer;//кол-во чисел, превосходящих ср. ариф

   m:array[1..n] of integer; //массив из 10 целых чисел

   i:byte; //счетчик цикла

begin

count:=0; avg:=0;

writeln('Введите в строку 10 чисел');

 for i:=1 to n do begin

  read(m[i]);//считываем в цикле 10 чисел

  avg:=avg+m[i];//подсчитываем сумму элементов  

end;

avg:=avg/10;//вычисляем среднее ариф. значение

 

//перебираем массив в цикле

for i:=1 to n do

    if (m[i]>avg) then count:=count+1;//если элемент массива больше чем ср. ариф, то счетчик таких чисел увеличиваем на 1

 

//вывод на экран требуемого значения

writeln(count);

end.

Объяснение:

попробовал все разъяснить в комментариях к строкам кода

0,0(0 оценок)
Ответ:
mmila4764
mmila4764
15.02.2021 20:03

const n=10;

var a:array [1..n] of integer;

i,s,k:integer;

begin

write('Массив: ');

randomize;

for i:= 1 to n do

begin

a[i]:= random(90)+10;

write (a[i]:3);

s:=s+a[i]

end;

writeln;

writeln('Среднее арифметическое элементов массива равно ',s/n);

k:=0;

for i:= 1 to n do

if a[i]>s/n then k:=k+1;

writeln('Количество элементов массива превосходящих среднее арифметическое  равно ',k)

end.

Объяснение:

В цикле:

1) задаём элементы массива

2) выводим их на экран

3) считаем сумму

В цикле:

по условию считаем количество элементов больших среднего арифметического

Вывод результат

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?