В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

1. составьте программу ввода и вывода массива: 5, -3, 4, -8, -9, 1, 9, 6, -3, 4, 8, 2. 2. составьте блок-схему алгоритма и программу вычисления в массиве a(10) количества нечетных элементов.

Ответ:
Hiccjhcvkjxg
Hiccjhcvkjxg
14.06.2020 15:46

1)

var a:array[1..12] of integer;
i,n,r:integer;
begin
n:=12;
a[1]:=5; a[7]:=9;
a[2]:=-3; a[8]:=6;
a[3]:=4; a[9]:=-3;
a[4]:=-8; a[10]:=4;
a[5]:=-9; a[11]:=8;
a[6]:=1; a[12]:=2;
for i:=1 to n do begin
writeln('Massiv a[',i,'] ', a[i]);
end;
end.

 

2)

var a:array [1..10] of integer;
i, n,k:integer;
begin
k:=0;
for i:=1 to 10 do
begin
write('a[',i,']:=');
readln(a[i]);
if not odd(a[i]) then
k:=k+1;
end;
writeln('Kolichestvo ne4etnix elementov - ', k);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?