В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
cska2003
cska2003
18.11.2020 21:18 •  Информатика

написать программу через Паскаль


написать программу через Паскаль

Ответ:
Geniud
Geniud
12.02.2021 22:37

A:

var

 s: string;

 i: integer;

begin

 Write('Введите строку: ');

 ReadLn(s);

 for i := 1 to length(s) do

 begin

   if s[i] = '.' then s[i] := '0' else

      if (s[i] = 'x') or (s[i] = 'X') then s[i] := '1' else

      begin

        s := 'Ошибка формата';

        break;

      end;

 end;

 WriteLn('Двоичный код: ', s);

end.

B:

var

 s: string;

 i: integer;

begin

 Write('Введите строку: ');

 ReadLn(s);

 for i := 1 to length(s) do

   if s[i] = '0' then s[i] := '1' else if s[i] = '1' then s[i] := '0';

 WriteLn('Инверсия: ', s);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?