В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Rita7711
Rita7711
21.08.2021 17:48 •  Информатика

написать программу на Паскале Нужно до завтра. 1)Напишите программу, которая в последовательности натуральных чисел определяет максимальное нечётное число.

Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется нечётное число. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — максимальное нечётное число.

2)Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — сумму чисел, оканчивающихся на 4.

Ответ:
akkusha1
akkusha1
13.01.2021 20:20

1)var n,a,i, max:integer;

begin

 writeln('ведите кол-во чисел');

 read(n);

 max:=0;

 for i:=1 to n do

 begin

   writeln('введите очередное число');

   read(a);

   if (a mod 2=1) and (a>max) then max:=a;

 end;

 writeln(max)

end.

2)var n,a,i, k:integer;

begin

 writeln('ведите кол-во чисел');

 read(n);

 k:=0;

 for i:=1 to n do

 begin

   writeln('введите очередное число');

   read(a);

   if  a mod 10 = 4 then k:=k+a;

   end;

   writeln(k)

   end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?