В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
romashka1899
romashka1899
27.06.2021 21:27 •  Информатика

написать программу на PascalABC.NET Нужно подсчитать количество студентов младше 16 лет, и вывести все данные о них

Ответ:
Anuliks
Anuliks
09.02.2021 22:11

var

 nm,snm:array of string;

 age:array of integer;

 k,s:integer;

begin

 

 write('Введите общее кол-во студентов - '); readln(k);

 setLength(nm,k); setLength(snm,k); setLength(age,k);

 for var i1:=0 to k-1 do begin

   writeln('[Студент ',i1+1,']');

   write('Имя     - '); readln(nm[i1]);

   write('Фамилия - '); readln(snm[i1]);

   write('Возраст - '); readln(age[i1]);

 end;

 

 for var i2:=0 to k-1 do

   if age[i2]<16 then s:=s+1;

 

 writeln; writeln('Кол-во студентов которым меньше 16 лет = ',s,' человек:');

 for var i2:=0 to k-1 do begin

   if age[i2]<16 then writeln(nm[i2],' ',snm[i2],' ',age[i2],' лет');

 end;

 

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?