В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
01Таня10
01Таня10
09.11.2021 13:12 •  Информатика

Написать программу на Паскаль: упорядочивание 4 чисел по возрастания

Ответ:
liana5101
liana5101
30.12.2020 09:10

Данная задача состоит из двух подзадач:

Определить цифры, из которых состоит число.

Отсортировать их в порядке возрастания.

Поскольку стоит вопрос о сортировке, то уместно цифры числа помещать массив. Цифры из заданного числа извлекаются путем последовательного нахождения остатка от деления на 10.

const N = 10;

var

   arr: array[1..N] of byte;

   m: longint;

   i, j, k, b: byte;

begin

   readln(m);

   k := 0;

   while m > 0 do begin

       k := k + 1;

       arr[k] := m mod 10;

       m := m div 10;

   end;

 

   for i:=1 to k-1 do

       for j:=1 to k-i do  

           if arr[j] > arr[j+1] then begin

               b := arr[j];

               arr[j] := arr[j+1];

               arr[j+1] := b;

           end;        

 

   for i:=1 to k do  

       write(arr[i],' ');

   writeln;

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?