В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Птичка56
Птичка56
07.06.2021 07:09 •  Информатика

Составьте программу, которая по введенным вами числам определит, могут ли эти числа быть длинами сторон треугольника. если да, то какого

Ответ:
Denis12o9
Denis12o9
14.06.2020 05:50

Основное условие что бы 3 числа могла быть сторонами треугольника это сумма каждых 2х чисел должна быть больше третьего.

 

Program Tri;

var a,b,c:real;

begin

readln(a);

readln(b);

readln(c);

if (a+b>c) and (a+c>b) and (b+c>a) then writeln ('могут быть треугольником');

end.

про то как определить какой это треугольник не знаю

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?