В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
natalipanshina
natalipanshina
28.12.2021 03:23 •  Информатика

3. Точка А задана координатами X,Y. Написать программу, которая выводит слово «Принадлежит», если точка принадлежит
заштрихованной области
и «не принадлежит» в противном случае протестировать
программу для
точек (0,0), (2,2),
(0.5,0.5), (0.5,-1.5), (-0.5,0.5), (-2,-1), (-1,-2), (-1, 1), (2, 0).


3. Точка А задана координатами X,Y. Написать программу, которая выводит слово «Принадлежит», если то

Ответ:
гсооагвгв
гсооагвгв
27.01.2021 18:08

program chik;

var x,y:real;

begin

readln(x,y);

if((y<=2)and(x>=-3)and(x<=2)and(y>=0))or

((y<=0)and(x>=-1)and(x<=1)and(y>=-1)and(x*x+y*y<=1))then

writeln('ПРИНАДЛЕЖИТ')else writeln('Не принадлежит');

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?