В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Spez18
Spez18
22.11.2022 17:41 •  Информатика

Язык программирования: C или C++. Написать программу. Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать первую половину по возрастанию, а вторую – по убыванию.

Ответ:
Anasteysha2610
Anasteysha2610
27.01.2021 13:16

#include <iostream>

#include <vector>

#include <cstdlib>

#include <ctime>

#include <algorithm>

using namespace std;

int main() {

vector<int> arr;

srand(time(0));

for (int i = 0; i < 10; ++i) {

 arr.push_back(rand() % 101);

 cout << arr[i] << " ";

}

cout << endl << "Sorted: ";

for (int j = 0; j < 100; ++j) {

 for (int i = 0; i < arr.size()-1; ++i) {

  if (i < 4) {

   if (arr[i] > arr[i + 1]) {

    swap(arr[i], arr[i + 1]);

   }

  }

  else {

   if (arr[i] < arr[i + 1]) {

    swap(arr[i], arr[i + 1]);

   }

  }

 }

}

for (int i = 0; i < 10; ++i) {

 if (i == 5) {

  cout << "/// ";

 }

 cout << arr[i] << " ";

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?