В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vladbortnovsij69
vladbortnovsij69
10.09.2020 17:49 •  Информатика

Написать программу в Паскале очень надо) Найти среднее арифметическое максимального и минимального элементов массива

Ответ:
ivanovgeorg123георг
ivanovgeorg123георг
25.01.2021 13:24

См объяснение + скриншот.

Объяснение:

program prog;

var

  a:array[1..5] of integer;

  max,min,i:integer;

  srednee:real;

begin

writeln('Zapolnim massiv iz 5 elementov:');

for i:=1 to 5 do readln(a[i]);

max:=a[1];

min:=a[1];

for i:=2 to 5 do begin

 if max<a[i] then max:=a[i];

end;

for i:=2 to 5 do begin

 if min>a[i] then min:=a[i];

end;

writeln('max=',max);

writeln('min=',min);

srednee:=(max+min)/2;

writeln('srednee arifm=',srednee);

end.


Написать программу в Паскале очень надо) Найти среднее арифметическое максимального и минимального э
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?