В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
AishaZamyjem8
AishaZamyjem8
06.05.2023 18:43 •  Информатика

по паскалю. Написать программу подсчета числа вхождений каждой буквы одного слова в другое слово.

Ответ:
kanevskiygabe
kanevskiygabe
24.01.2021 19:46

var s,s1:string;

i,j,count:integer;

begin

read(s);

for i:=length(s) downto 2 do

for j:=2 to i do

if s[j]<s[j-1] then begin

swap(s[j],s[j-1]);

s1:=s;

end;

//сортируем строку в алфавитном порядке чтобы потом было легче

//считать количество встреч одного и того же символа

count:=1;

write(s1[1],': ');

//первый символ в любом случае встречается один раз

for i:=2 to length(s1) do

if s1[i]=s1[i-1] then inc(count) else begin

writeln(count);

write(s1[i],': ');

count:=1

end;

//считаем количество совпадений для каждого символа

writeln(count);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?