В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sukhovilopolina
sukhovilopolina
10.12.2021 16:41 •  Информатика

Составить программу которая возводит в 3 степень положительные элементы массива а15 и выводит модуль числа отрицательного элемента этого массива

Ответ:
eiapple02
eiapple02
23.01.2021 20:38

program z1;

var i:integer;

a:array[1..15] of integer;

begin

for i := 1 to 15 do

begin

a[i]:=random (11) - 5;

write (a[i]:5)

end;

writeln;

for i := 1 to 15 do

begin

if a[i] > 0 then a[i]:=sqr(a[i])*a[i];

if a[i] < 0 then a[i]:=abs(a[i]);

write (a[i]:5)

end

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?