В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
кфг
кфг
17.12.2022 12:33 •  Информатика

составить программу которая найдёт в линейном массиве сумму отрицательных элементов через генератор случайных чисел числа очень я в информатике- ноль

Ответ:
викусик150
викусик150
23.01.2021 15:34

var i,s: integer;

a: array [1..10] of integer;

begin

write('Массив ');

for i:=1 to 10 do

begin

a[i]:=random(71)-30;

write (a[i]:4);

if a[i]>0 then s:=s+a[i]

end;

writeln;

write('Сумма положительных элементов массива ',s)

end.

Объяснение:

a[i]:=random(71)-30 если от -30 до 40 включительно

A[i]:= random (70)-30 если от -30 до 39 включительно

я не знаю правельна или неправельна

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?