В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Xrayl
Xrayl
17.06.2022 01:32 •  Информатика

Написать программу или хотя бы объясните, что от меня вообще количество элементов к каждому столбцу прямоугольной вещественной матрицы, меньших среднего арифметического всех элементов, рассмотренного столбца.

Ответ:
AnnaDor
AnnaDor
24.05.2020 12:16

var a:array [byte,byte] of real;
i,j,n,m:byte;
s:real;
d,p:word;

begin
write('Введите количество строк n = ');readln(n);
write('Введите количество строк m = ');readln(m);
for i:=1 to n do
for j:=1 to m do
readln(a[i,j]);

s:=0;d:=0;p:=0;
for i:=1 to m do begin
for j:=1 to n do
s:=s+a[j,i];
for j:=1 to n do
if a[j,i]<(s/n) then inc(d);
writeln('Количество элементов в столбце ',i,' прямоугольной вещественной матрицы, меньших среднего арифметического d = ',d,' Среднее арифметическое = ',(s/n):0:4);
p:=p+d;
d:=0;s:=0;
end;
writeln('Общее количество элементов меньших элементов в столбцах = ',p);
writeln('Матрица');
for i:=1 to n do begin
for j:=1 to m do
write(a[i,j],' ');
writeln;
end;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?