В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
anastasiasestak
anastasiasestak
07.03.2021 00:30 •  Информатика

Напишите программу, которая находит все числа в диапазоне от a до b , сумма цифр которых не меняется при умножении на 2,3,4,5,6,7,8 и 9 (например, число 9). Используйте функцию для вычисления суммы цифр числа.


Напишите программу, которая находит все числа в диапазоне от a до b , сумма цифр которых не меняется

Ответ:
GOKAS
GOKAS
23.01.2021 10:09

def smm_numbers(x):

  sm = 0

  sm_num = 0

  for _ in x:

      sm += int(_)

  for j in range(2, 10):

      j = str(j * int(x))

      for p in j:

          sm_num += int(p)

      if sm_num != sm:

          return False

      sm_num = 0

  return True

a, b = map(int, input().split())

count = 0

for i in range(a, b + 1):

  if smm_numbers(str(i)):

      print(i)

      count += 1

if count == 0:

  print(0)

Объяснение:

соблюдайте отступы что бы избежать синтаксической ошибки

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?