В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vaider222
vaider222
31.07.2022 02:51 •  Информатика

Составьте программу которая запрашивает значения элементов одномерного числового массива а, стоящего из 10 элементов,формирует и выводит на экран в строку данный массив. найти сумму неположительных элементов массива,количество элементов кратных 3, произведение элементов,стоящих на четных местах

Ответ:
kolya0125
kolya0125
14.06.2020 00:43

program z1;
uses crt;
var m: array[1..10] of integer;
i,a,b,c:integer;
begin
for i:=1 to 10 do
readln(m[i]);
writeln;
a:=0;
b:=0;
c:=1;
for i:=1 to 10 do
begin
 if m[i]<=0 then a:=a+m[i];
if m[i] mod 3 = 0 then b:=b+1;
if i mod 2 = 0 then c:=c*m[i];
end;
writeln(Сумма отриц'',a);
writeln(кратные 3'',b);
writeln(произв'',c)
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?