В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
DanilNaumov
DanilNaumov
19.07.2020 05:37 •  Информатика

4. Составьте программу, выдающую результат следующего выражения: (1+2)*(1+2+3)*...*(1+2+...+10)
5. Задано натуральное число N. Найти количество натуральных чисел, не
превосходящих его и не делящихся ни на одно из чисел 2, 3, 5.
на PHyton

Ответ:
zhosik1alika
zhosik1alika
22.01.2021 20:31

4)

numbers = []

for i in range(1, 11):

 numbers.append(0)

 for z in range(1, i + 1):

   numbers[i - 1] += z

composition = numbers[0]

for i in range(1, len(numbers)):

 composition *= numbers[i]

print(composition)

5)

n = int(input())

amountOfNumbers = 0

for i in range(n + 1):

 if i % 2 != 0 and i % 3 != 0 and i % 5 != 0:

   amountOfNumbers += 1

print(amountOfNumbers)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?