В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
dashvali
dashvali
13.09.2022 15:37 •  Информатика

Написать программу на паскале: "если введенное целое число является трехзначным, то удалить из него среднюю цифру; если число двухзначное, то удвоить крайние цифры; иначе – выдать сообщение «ошибка ввода»."

Ответ:
Никаgyvhbbuh
Никаgyvhbbuh
14.06.2020 00:22

program z1;
uses crt;
var n:integer;
begin
writeln(''вв число');
readln(n);
if n>999 then writeln('ошибка ввода') else
if n>100 then writeln((n div 100)*10+n mod 10 ) else
writelnn div 10)*2)*10)+((n mod 10)*2));
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?