В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Milediteul
Milediteul
09.06.2023 11:13 •  Информатика

(в паскале надо сделать)«карусель»карусель – одна из популярных форм проведения командных соревнований по решению .всем , участвующим в карусели, предлагаются в строгом порядке одни и те же , которые необходимо решить в установленное время. система подсчета такова, что доминирующим фактором является не количество решенных , а длины последовательностей правильных решений.начисление происходит согласно следующей схеме: первая стоит 3 ; если к дан верный ответ, то команда получает ее стоимость, а следующая будет стоить на 1 больше; если на дан неверный ответ, то команда получает за решение 0 , а следующая будет стоить на 3 меньше, но не менее 3 .вам требуется написать программу, которая по результатам ответов команды определит итоговый .первая строка входных данных содержит натуральное число n – количество в карусели (n ≤ 105). во второй строке расположены n цифр 0 или 1, разделенные пробелом; i-я цифра соответствует корректности ответа команды на i-ю (0 – неверный ответ, 1 – верный ответ).

Ответ:
polycov200412
polycov200412
01.10.2020 00:45

program raf105;

var

 s,s2: string;

 i,j,n,price,points: integer;

begin

write('Количество задач в карусели: ');

readln(n);

write('ответы команды: ');

readln(s);

for i:=1 to length(s) do

 if s[i]<>' '

   then s2:= s2 + s[i];

price:= 3;

for i:=1 to length(s2) do

begin

 if s2[i]='1'

   then begin

     points:= points + price;

     price:= price + 1;

   end

   else for j:=1 to 3 do

     if price > 3

       then price:= price-1;

end;

writeln('Итоговый : ',points);

end.

PascalABC 3.4.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?