В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
zanna74
zanna74
03.08.2021 22:06 •  Информатика

Написать программу, которая выводит на экран значения элементов массива в обратном порядке. в массиве 10 элементов, массив заполняется с случайных чисел из интервала (0, 100). (паскаль)

Ответ:
салмик
салмик
13.06.2020 22:13

 Program Massiv2;

Uses Crt;

var a:array[1..10] of integer;

       i:integer;

begin

     clrscr;

 

    randomize;

    for i:=1 to 10 do a[i]:=random(100)+1;

    write('Массив в обратном порядке: ');

     for i:=10 downto 1 do write(a[i],' ');  

     readkey;

 

 end.

0,0(0 оценок)
Ответ:
sofa286
sofa286
13.06.2020 22:13

Вот программа на C, выводит массив в прямом и обратном порядке:

 

#include <stdio.h>
#include <time.h>

void func(int *array, int n, int i)
{
  if (i < n) {
    array[i] = 0 + rand() % 100;
    printf("%d ", array[i]);
    func(array, n, i + 1);
    printf("%d ", array[i]);
  }
  else {
    printf("\n");
  }
}

int main(int argc, char *argv)
{
  srand(time(NULL));
  int array[10];
  func(array, 10, 0);
  return 0;
}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?