В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
d7175944p0ajvy
d7175944p0ajvy
12.09.2020 23:57 •  Информатика

Задание 5. Составьте программу подсчета количества часов, минут и секунд в данном числе суток. Число суток введите с клавиатуры.​

Ответ:
sydykovadiana
sydykovadiana
21.01.2021 20:30

Неправильно считает секунды, в чём ошибка?

var

s,m,h,days: integer;

begin

writeln('Введите кол-во дней');

read(days);

s:=86400;

m:=s div 60;

h:=m div 60;

for var i:=1 to days do

s:=s*days;

m:=m*days;

h:=h*days;

writeln(s,' — секунд в ',days,' днях');

writeln(m,' — минут в ',days,' днях');

writeln(h,' — часов в ',days,' днях');

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?