В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
илья20032101
илья20032101
24.04.2023 04:08 •  Информатика

Составить программу в паскале: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.: · если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел. · если произведение этих чисел больше их суммы, то выведите эти сумму и произведение. · если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму · иначе, выведите удвоенные значения этих чисел

Ответ:
Jora2001Voronov
Jora2001Voronov
13.06.2020 21:46

var
a,b,c,d:real;
begin
readln (a,b,c,d);
if ((a<0) and (b=2*c)) and ((a*b*c*d)>a+c+c+d)
then
begin
writeln ('Среднее арифметическое: ',(a+b+c+d)/4);
writeln ('Произведение: ', a*b*c*d);
writeln ('сумма:',a+b+c+d)
end
else
if (a<0) and (b=2*c)
then writeln ('Среднее арифметическое: ',(a+b+c+d)/4)
else
if ((a*b*c*d)>(a+c+c+d))then

begin
writeln ('Произведение: ', a*b*c*d);
writeln ('сумма:',a+b+c+d)
end
else writeln (2*a,' ',2*b,' ',2*c,' ',2*d);
end.

0,0(0 оценок)
Ответ:
gusew7kaja
gusew7kaja
13.06.2020 21:46

program p

var

 a,b,c,d : integer;

begin

readln(a),

readln(b),

readln(c),

readln(d),.

if (a<0) and (b/c=2) then witeln ((a+b+c+d)/4);

if (a*b*c*d>a+b+c+d) then begin witeln (a+b+c+d);witeln (a*b*c*d);end;

if (a*b*c*d>a+b+c+d)and((a<0) and (b/c=2)) then begin end else

begin

writeln(2*a) ;

writeln(2*b) ;

writeln(2*c) ;

writeln(2*d) ;

end;

 

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?