В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
accacherrygdghvcg
accacherrygdghvcg
23.08.2020 20:49 •  Информатика

Несложная программа на python! Написать программу которая в каждую новую строку выводит новое число за логикой: 0+1-2+3-4+5-6+7-8+9-10 (результат каждой новой операции должен выводится в новую строку). Думаю всё понятно, если есть вопросы - спрашивайте.

Ответ:
irenda828001
irenda828001
21.01.2021 01:17

s = 0

for i in range(1,12):

   print(0,end=" ")

   for j in range(1,i):

       if j % 2 == 0:

           print('-',j,end=" ")

           s -= j

       else:

           print('+',j,end=" ")

           s += j

   print('=', s)

   s = 0

   print()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?