В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
oxle
oxle
05.05.2021 18:52 •  Информатика

Написать программу на Pascal,которая на вход получает любое натуральное целое число. На выходе программа сообщает сумму всех цифр и произведение всех нечётных цифр числа. Гарантируется, что в числе есть и чётные и нечётные цифры.

Ответ:
drfast555
drfast555
17.01.2021 00:08

Не совсем верно, но очень близко.

uses crt;

const nmax=100;

var a:array[1..nmax] of integer;

n,i,j,k:byte;

begin

clrscr;

repeat

write('Размер массива до ',nmax,' n=');

readln(n);

until n in [1..nmax];

writeln('Введите элементы массива:');

for i:=1 to n do

begin

write('a[',i,']=');

readln(a[i]);

end;

clrscr;

writeln('Массив:');

for i:=1 to n do

write(a[i]:4);

writeln;

writeln;

k:=0;

for i:=1 to n-1 do

for j:=i+1 to n do

if a[j]=a[i] then k:=k+1;

if k=1 then write('В массиве только 2 одинаковых элемента')

else write('В массиве не 2 одинаковых элемента');

readln

end.

Объяснение:

0,0(0 оценок)
Ответ:
Kosmen21
Kosmen21
17.01.2021 00:08

##

var n: BigInteger;

while True do

begin  

 var s := ReadString('Введи число:');

 if BigInteger.TryParse(s, n) then

   break

 else

   Println('Неверный ввод, повторите')

end;  

n := Abs(n);

var (s, p) := (0bi, 1bi);

while n > 0 do

begin

 var d := n mod 10;

 s += d;

 if d mod 2 <> 0 then p *= d;

 n := n div 10

end;

Print(s, p)


Написать программу на Pascal,которая на вход получает любое натуральное целое число. На выходе прогр
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?