В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kakashonka1
kakashonka1
05.08.2020 23:58 •  Информатика

Напишите программу, которая сортирует массив и выводит все элементы массива, которые встречаются ровно K раз.


Напишите программу, которая сортирует массив и выводит все элементы массива, которые встречаются ров

Ответ:
vyaskin2018
vyaskin2018
16.01.2021 10:30

Код:

list_of_words = {}

searched_num = 0

arr_count = int(input("Введите количество элементов: "))

if arr_count < 0 or arr_count > 1000:

   exit(print("\nНеверное количество элементов!"))

arr = sorted(input("\nВведите массив через пробел: ").split())

oftn_num = int(input("\nВведите число: "))

if arr_count != len(arr):

   exit(print("\nКоличество элементов не совпадает!"))

for i in arr:

   if i in list_of_words:

       list_of_words[i] += 1

       continue

   list_of_words[i] = 1

for key, val in list_of_words.items():

   if val == oftn_num:

       print(key, end=' ')

       searched_num += 1

if not searched_num:

   print(0)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?