В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
burdick94
burdick94
25.04.2023 17:03 •  Информатика

Паскаль 1-ая девочка купила 3 булочки за Б руб. коп. и 6 конфет за В руб. коп.
2-ая девочка купила 5 булочек за Д руб.коп. и 4 конфеты за Г руб.коп. Написать программу,которая показывает сколько каждая из них заплатила и кто больше

Ответ:
almaziksky311
almaziksky311
15.01.2021 11:27

var b,v,d,g,d1,d2:real;

begin

writeln('Б руб: ');

readln(b);

writeln('В руб: ');

readln(v);

writeln('Д руб: ');

readln(d);

writeln('Г руб: ');

readln(g);

if (3*b + 6*v) > (5*d + 4*g) then begin

 writeln('1 девочка заплатила больше');

 d1:=3*b+6*v;

 d2:=5*d+4*g;

 end

 else

   if (5*d + 4*g) > (3*b + 6*v) then begin

   writeln('2 девочка заплатила больше');

   d1:=3*b+6*v;

   d2:=5*d+4*g;

   end

   else if (5*d + 4*g) = (3*b + 6*v) then begin

     d1:=3*b+6*v;

     d2:=5*d+4*g;

     writeln('девочки заплатили одинаково');

     end;

     writeln;

     writeln('1 девочка: ',d1,' руб');

     writeln('2 девочка: ',d2,' руб');

end.


Паскаль 1-ая девочка купила 3 булочки за Б руб. коп. и 6 конфет за В руб. коп. 2-ая девочка купила 5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?