В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
GremMaster
GremMaster
14.03.2021 00:15 •  Информатика

Впаскале. пусть в массиве содержатся результаты измерений температуры воздуха за декабрь, которые проводились ежедневно. определите сколько дней в декабре температура была выше средней.

Ответ:
Майнур1234567890
Майнур1234567890
13.06.2020 11:16

const d = 31;
var
  a: array[1..d] of integer;
  i, count, mdl: integer;
begin
  for i := 1 to d do begin
    a[i] := random(31);
    write(a[i], ' ');
    mdl := mdl + a[i];
  end;
  writeln;
  writeln('Средняя температура: ', (mdl / d):0:2);
  for i := 1 to d do
    if(a[i] > mdl / d) then inc(count);
  writeln('Дни, в которые температура была выше средней: ', count);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?