В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
aiperiwa
aiperiwa
10.01.2020 00:06 •  Информатика

с информатикой: Составить программу, включающую меню из четырех пунктов: 1.Создать файл записей (не менее трех), которые содержат два поля (фамилия, оценка). 2.Вывести содержимое файла на экран. 3.Добавить новую запись и упорядочить список по алфавиту. 4.Выход. Первые три пункта меню реализовать в процедурах, которые поместить в модуль.

Ответ:
777Leha777
777Leha777
14.01.2021 14:32

Запись 5 строк в файл }

procedure TForm1.Button1Click(Sender: TObject);

var outfile: TextFile;

begin

AssignFile(outfile, 'outfile.txt')

;Rewrite(outfile);

writeln(outfile, 'Привет из Delphi');

writeln(outfile, 'Моя программа работает, и выводит '

+'данный текст, чтобы доказать это...');

writeln(outfile, '3. Треться строка');

writeln(outfile, '234 четвертая');

writeln(outfile, 'Пятая строка');

CloseFile(outfile);

end;

// вывод на экран точнее в мемо или лист бокс

procedure TForm1.Button2Click(Sender: TObject);

begin

// выводим в мемо

Memo1.Lines.LoadFromFile('outfile.txt');

// либо в лист бокс как тебе лучше

ListBox1.Items.LoadFromFile('outfile.txt');

end;

// кнопка для закрытия

procedure TForm1.Button3Click(Sender: TObject);

begin

Close;

end;

// событие onClose

procedure TForm1.FormClose(Sender: TObject; var CloseAction: TCloseAction);

begin

if MessageDlg('Вы точно хотите выйти?', mtConfirmation, mbOkCancel,0)= mrOk then begin

CloseAction:= caFree;

end

else begin

CloseAction:= caNone;

end;

end;

ЗДЕСЬ!

outfile.txt - это ваш файл(может создаваться автоматически

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?