В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
СабинаЛис
СабинаЛис
17.02.2021 00:23 •  Информатика

Составить программу для ввода в ЭВМ произвольной цело-численной матрицы размером M*N и определения координат и значения наименьшего по модулю элемента этой матрицы.

Ответ:
zzaaiirra
zzaaiirra
14.01.2021 14:03

m, n, i, j: integer;

 s: real;

 a: array[,] of real;

 

 write('Введите S: ');

 read(s);

 write('Введите M, N: ');

 read(m, n);

 setlength(a, m + 1, n + 1);

 writeln('Введите элементы матрицы: ');

 for i := 1 to m do

   for j := 1 to n do

     read(a[i, j]);

 for i := 1 to m do

 begin

   for j := 1 to n do  

     if a[i, j] <> s then

     begin

       writeln(a[i, j]);

       break;

     end;

   if a[i, j] = s then

     writeln('-');

 end;

end.

Пример:

Введите S: 7

Введите M, N: 3 4

Введите элементы матрицы:

7 4 3 7

3 5 1 4

7 7 7 7

4

3

-

Объяснение:

нажмите лучших ответ и лайк

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?