В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ormnjkfgfff
ormnjkfgfff
30.10.2022 20:31 •  Информатика

Решить на паскале я совсем не разбираюсь в ! 1)дана таблица со значениями среднемесячных температур в течение года. составить программу на паскале, в которой вычисляются четыре величины: средние температуры
зимних месяцев, весенних месяцев, летних и осенних. 2)вы посетили магазин и купили 10 видов товара. в таблицу t [1..10] записали количество купленного товара каждого вида. в таблицу c [1..10] записали цену единицы каждого
вида товара соответственно. составить программу на паскале вычисления общей стоимости всех покупок.

Ответ:
alinnnkaaa
alinnnkaaa
24.05.2020 11:45

1)var t: array [1..12] of real;

      i: integer;

begin

  for i:=1 to 12 do readln(t[i]);

  writeln('Средняя температура зимних месяцев: ',((t[12]+t[1]+t[2])/3):0:3);

  writeln('Средняя температура весенних месяцев: ',((t[3]+t[4]+t[5])/3):0:3);

  writeln('Средняя температура летних месяцев: ',((t[6]+t[7]+t[8])/3):0:3);

  writeln('Средняя температура осенних месяцев: ',((t[9]+t[10]+t[11])/3):0:3);

end.

2)var t: array[1..10] of integer;

         c: array[1..10] of real;

         i: integer;

         s,s1: real;

begin

  s:=0;

  for i:=1 to 10 do begin writeln('Введите количество товара'); readln(t[i]) ; end;

  for i:=1 to 10 do begin writeln('Введите цену товара');readln(c[i]);end;

  for i:=1 to 10 do begin s1:=t[i]*c[i];

                                    s:=s+s1;

                           end;

  writeln('Общая стоимость всех покупок: ',s:0:3);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?