В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Tini2311
Tini2311
01.07.2021 03:26 •  Информатика

Решить в паскале (без массива) №1 составьте не менее трёх вариантов программы определения наименьшего их трех данных чисел. №2 составить программу сортировки по возрастанию значений трёх переменных : а,в,с . №3 заданы размеры а,в прямоугольного отверстия x,y,z кирпича. определить пройдет ли кирпич через отверстие .

Ответ:
shalyaeg
shalyaeg
13.06.2020 07:53

Первые два вчера

 

В третьем не уверен в самом алгоритме...

 

var

  a, b, x, y, z : real;

begin

  read (a, b, c, x, y);

  if ((a <= x) and (b <= y)) or ((a <= y) and (b <= x))

  or ((a <= x) and (b <= z)) or ((a <= z) and (b <= x))

  or ((a <= z) and (b <= y)) or ((a <= y) and (b <= z)) then writeln ('YES') else writeln ('NO');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?