В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ольга1724
ольга1724
15.07.2022 16:01 •  Информатика

1. написать программу нахождения суммы чисел от 1 до 24. 2 написать программу печати трех чисел, выведенных с клавиатуры, в порядке возрастания

Ответ:
yasmina143
yasmina143
01.10.2020 00:16

1)

 

var
  i, s: integer;
begin
  for i := 1 to 24 do s := s + i;
  writeln(s);
end.

 

2)

 

var
  a, b, c : integer;

procedure swap(var a, b : integer);
  var k : integer;
  begin
    k := a; a := b; b := k;
  end;

begin
readln(a, b, c);
  if a > b then swap (a, b);
  if a > c then swap (a, c);
  if b > c then swap (b, c);
  writeln(a, ' ', b, ' ', c);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?