В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Решить написать программу на языке паскаль продав квартиру, вы получили 22000 долларов и положили их в банк. банк начисляет 18% в первый месяц, а каждый следующий - тоже 22%, но уже с общей суммы с учётом начисленных процентов. сколько денег будет в банке на вашем счету через год? (нестабильностью нашей системы пренебрегаем)

Ответ:
EgoSik1
EgoSik1
13.06.2020 05:58

var
  i: integer;
  s: real;
begin
  for i := 1 to 12 do begin
    if(i = 1) then s := 22000 + (22000 * 0.18) else
    s := s + (s * 0.22);
  end;
  writeln(s:0:3);
end.

0,0(0 оценок)
Ответ:
1981katerina
1981katerina
13.06.2020 05:58

В принципе, решение формально арифметически правильное. НО ведь задача нереальна.

1. Как правило, резидентам законодательно запрещено осуществлять на территории своего государства сделки не в валюте государства, значит эта сделка была либо серой(на бумаге одно, в реале другое), либо сделка осуществлялась на территории другого государства, где покупатель был нерезидентом.

2. Таких ОГРОМНЫХ процентов по депозитным валютным вкладом НЕ СУЩЕСТВУЕТ В ПРИНЦИПЕ,  это же около 300% годовых в валюте! Это под какие же процены банк должен выдавать кредиты, чтобы привлечённые ресурсы были рентабельные, да и кто их под такие проценты возьмёт!. Реальные проценты по депозитным вкладам 5-10% ГОДОВЫХ.

 

Я не случайно написал этот комментарий, ведь если по физике вам предложат задачу, ну например, такую "Сколько времени продлится полет на Марс, если расстояние до него 60000000км, а скорость космолёта 500000км/с", вы ведь не будете её решать, потому что такой скорости не может быть. Так и здесь: таких процентов не может быть! Поэтому решать такую задачу нельзя, она описывает не существующие объекты(ситуацию).

 

Вот и всё!

Успехов!

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?