В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
badurina92p0cc49
badurina92p0cc49
07.05.2023 09:00 •  Информатика

Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). количество чисел не превышает 100. введённые числа по модулю не превышают 300. программа должна вывести среднее арифметическое чисел, кратных 9, или вывести no, если таких чисел в последовательности нет.

Ответ:
Morkovka911
Morkovka911
13.06.2020 05:26

var
  a, i, count, s: integer;
begin
  repeat
    if(i = 100) then break;
    readln(a);
    if(abs(a) > 300) then begin
      writeln('Число по модулю не может быть > 300.');
      continue
    end
    else if(a mod 9 = 0) and (a <> 0) then begin
      inc(count);
      s := s + a;
    end;
    if(a <> 0) then inc(i);
  until(a = 0);
  writeln('Среднее арифметическое: ', s / count);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?