В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
feliz3600
feliz3600
22.04.2021 07:14 •  Информатика

Как написать программу которая напишет все целые числа от 1 до 50 которые кратны 9 и посчитает их произведение и сумму

Ответ:
weazelhubozcy1c
weazelhubozcy1c
13.06.2020 03:58

Берем цикл от 1 до 50, идем и проверяем все числа на кратность 9, если кратны, то пишем число и добавляем к сумме (и умножаем произведение).

 

var

  sum, mul, i : integer;

begin

   sum := 0; mul := 1;

  for i := 1 to 50 do

    if i mod 9 = 0 then

    begin

      write (i, '  ');

      sum := sum + i;

      mul := mul * i;

    end;

  writeln;

  writeln ('sum = ', sum);

  writeln ('mul = ', mul);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?