В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lazmax2000
lazmax2000
05.05.2022 01:05 •  Информатика

Написать программу создающую массив из N целых элементов со случайными значениями в диапазоне [-50; 50]. Подсчитать среднее арифметическое элементов массива, кратных трем.

Ответ:
RedZilla54
RedZilla54
09.01.2021 21:08

const n=20;

var a:array[1..n] of integer;

i,b,c:integer; k:real;

Begin

for i:=1 to n do read(a[i]);

b:=0;

c:=0;

for i:=1 to n do begin

if (a[i] mod 3 = 0) then begin

b:=b+a[i];

c:=c+1;

end;

end;

 

k:=b/c;

writeln(k);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?