В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Lala19962
Lala19962
03.04.2023 15:33 •  Информатика

Задачи на списки в Python: 1. Тре­бо­ва­лось на­пи­сать про­грам­му, при вы­пол­не­нии ко­то­рой с кла­ви­а­ту­ры вво­дит­ся по­сле­до­ва­тель­ность из шести не­от­ри­ца­тель­ных целых чисел, не пре­вы­ша­ю­щих 10^6, под­счи­ты­ва­ет­ся и вы­во­дит­ся сумма введённых чётных чисел или 0, если чётных чисел в по­сле­до­ва­тель­но­сти нет.
2. Тре­бо­ва­лось на­пи­сать про­грам­му, при вы­пол­не­нии ко­то­рой с кла­ви­а­ту­ры вво­дит­ся по­сле­до­ва­тель­ность из шести не­от­ри­ца­тель­ных целых чисел, не пре­вы­ша­ю­щих 10^6, под­счи­ты­ва­ет­ся и вы­во­дит­ся сумма введённых чётных чисел или 0, если чётных чисел в по­сле­до­ва­тель­но­сти нет.
2. На обработку поступает последовательность из четырёх неотрицательных целых чисел (некоторые числа могут быть одинаковыми). Нужно написать программу, которая выводит на экран количество чётных чисел в исходной последовательности и максимальное чётное число. Если чётных чисел нет, требуется на экран вывести «NO». Известно, что вводимые числа не превышают 1000.

Ответ:
igor1337d
igor1337d
10.12.2020 16:20

# 1

count = 0

for i in range(6):

   a = int(input())

   if a % 2 == 0:

       count += a

print(count)

# 2

count = 0

for i in range(6):

   a = int(input())

   if a % 2 == 0:

       count += a

print(count)

# 3

count = ""

maximum = 0

for i in range(4):

   a = int(input())

   if a % 2 == 0:

       count += f"{str(a)} "

       if a > maximum:

           maximum = a

if count == "":

   print("NO")

else:

   print(count)

   print(maximum)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?