В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
1234567890825
1234567890825
21.03.2021 12:44 •  Информатика

Надо составить программу на языке Паскаль АБС для получения таблицы истинности. Для этого надо A и B присвоить 0 to 1 do.(цикл for) Надо получить таблицу истинностьи A and B и not A

Ответ:
alex27045
alex27045
08.01.2021 08:35

var A,B,C:boolean;

function f(C,B,A:boolean):boolean;

begin

f:=((A and C) and(not B))and(B or A);  

end;

begin

writeln('C':7,'B':7,'A':7,'F':7);

for C:=false to true do

for B:=false to true do

for A:=false to true do

writeln(C:7,B:7,A:7,f(C,B,A):7);

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?