В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
алана24
алана24
11.06.2020 22:07 •  Информатика

Напишите программу(на Паскале) вычисления суммы всех положительных элементов массива, которые вводятся с клавиатуры

Ответ:
060609
060609
07.01.2021 05:56

var i, sum, num : integer;

var D: array [0..10] of integer;

begin

 sum := 0;

 

 for i:= 0 to 10 do begin

   readln(num);

   D[i] := num;

 end;

 

 for i := 0 to 10 do begin

   if D[i] >= 0 then

     sum := sum + D[i];

 end;

 

 writeln('Результат = ' + sum);  

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?