В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
akimova5
akimova5
12.11.2022 01:19 •  Информатика

Напишите программу, которая вычисляет сумму элементов последовательности целых чисел, поданных не её вход. Ввод заканчивается числом 0. ---Входные данные---
Во входных строках записаны целые числа, по одному в каждой строке. В последней строке записано число 0.

---Выходные данные---
Программа должна вывести одно число – сумму всех элементов последовательности.
ПРИМЕР
Ввод
1
2
3
0
Вывод
6
Ввод
-1
-2
-3
-4
0
Вывод
-10
Желательно на Питоне или Паскале с использованием РЕКУРСИИ(функции или процедуры)!

Ответ:
Кристи626
Кристи626
07.01.2021 04:36

Задачи в 1 действие -_-

#include <iostream>

using namespace std;

int main()

{

   long long a, sum = 0;

   while(1)

   {

       cin >> a;

       if(a == 0)

           break;

       else

           sum+=a;

   }

   cout << sum << endl;

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?