В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Кобра228322
Кобра228322
20.01.2020 13:29 •  Информатика

Напишите программу, которая выводит полученную последовательность чисел в обратном порядке. Использовать массив для хранения последовательности не разрешается. ---Входные данные---
Во входных строках записаны целые числа, по одному в каждой строке. В последней строке записано число 0.

---Выходные данные---
Программа должна вывести элементы полученной последовательности в обратном порядке в одну строчку, разделив их пробелами.
ПРИМЕР
Ввод
1
2
3
0
Вывод
3 2 1
Ввод
245
-7197
0
Вывод
-7197 245
Желательно на Питоне или Паскале с использованием РЕКУРСИИ(процедуры или функции)!

Ответ:
alexxpopovruu
alexxpopovruu
07.01.2021 03:38

Мне становится страшно за твой уровень развития 0_0

#include <iostream>

using namespace std;

long long b[100000];

int main()

{

   long long a, sum = 0, i = 0;

   while(1)

   {

       cin >> a;

       if(a == 0)

           break;

       b[i] = a;

       i++;

   }

   for(i--; i > -1; i--)

   cout << b[i] << " ";

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?