В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Анюта10072401
Анюта10072401
12.06.2021 12:39 •  Информатика

Нужно решить задачу (нужно решить на язике С++) Написать программу которая определяет является ли введенное число простым или нет

ввод: 2

вывод: Yes

ввод: 5

вывод: Yes

ввод: 179

вывод: No

Ответ:
bananchik1213
bananchik1213
07.01.2021 01:33

ответ:#include <iostream>

using namespace std;

void myFunc(int k) {

bool flag = true;

for(int i=2; i<k; i++)

{

 if(k%i==0)

 {

  flag = false;

 }

 

}

if(flag==true)

{

 cout<<"Yes"<<endl;

}

else

{

 cout<<"No"<<endl;

}

}

int main(int argc, char** argv) {

int a;

cout<<"Input a: ";

cin>>a;

myFunc(a);

return 0;

}

Объяснение: Создаем функцию которая ничего не возвращает, она принимает аргумент К. Это и есть число какое будем вводить. Создаем буллевую переменную. Делаем цикл с числа 2. Т.к 1, 2 простые. Смысла проверять нет. Если остатка от деления числа К на І не будет - значит оно не простое. Далее проверяем наш flag, main думаю понятно

P.S: Если не там Yes или No просто поменяй их текст

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?