В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
EvilMorty
EvilMorty
28.11.2022 04:33 •  Информатика

1. Написать программу вычисления сумм всех положительных элементов массива вводимых с клавиатуры. 2. Написать программу вычисления кол-ва нечетных чисел массива.
3. Написать программу поиска наименьшего элемента массива

Ответ:
номе498
номе498
07.01.2021 00:53

const

 n = 25;

 

var

 a: array[1..n] of integer;

 k0, k, i, s: integer;

 p: real;

 

begin

 s := 0;

 p := 1;

 k := 0;

 k0 := 0;

 for i := 1 to n do

 begin

   a[i] := -n div 2 + random(n);

   Write(a[i]:4);

   if a[i] = 0 then

     inc(k0);

   if a[i] > 0 then

     s := s + a[i];

   if a[i] < 0 then

   begin

     p := p * a[i];

     inc(k);

   end;

 end;

 WriteLn;

 Writeln('Сумма: ', s);

 Writeln('Количество 0: ', k0);

 if k <> 0 then

   Writeln('Произведение: ', p)

 else

   Writeln('Нет таких чисел. ')

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?