В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Romchik1111111
Romchik1111111
21.05.2020 23:54 •  Информатика

Написать программу! ) в эвм по очереди поступают результаты соревнований ,в которых участвуют n спортсменов.составьте программу,которая обеспечивает вывод на экран лучшего результата каждыйраз после ввода
результата очередного спортсмена

Ответ:
tatyana171283t
tatyana171283t
24.05.2020 11:12

var n,i: integer;

      result,thebest: real;

begin

  thebest:=1;

  writeln('Введите количество спортсменов');

  readln(n);

  for i:=1 to n do begin

    writeln('Введите результат ',i,' спортсмена');

    readln(result);

    if result>thebest then thebest:=result;

    writeln('Лучший результат: ',thebest);

                         end;

end.

    

  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?