В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
korsukova61oye48j
korsukova61oye48j
24.03.2023 19:41 •  Информатика

Написать программу нахождения большего и меньшего из 3 чисел

Ответ:
dasssshka1
dasssshka1
12.06.2020 21:26

var a,b,c:integer;
begin
readln(a,b,c);
if (a>b) and (a>c) and (b>c) then writeln('c=',c,'a=',a) else
if (b>a) and (b>c) and (a>c) then writeln('c=',c,a,'b=',b) else
if (c>a) and (c>b) and (b>a) then writeln('a=',a,'c=',c) else
if (a>b) and (a>c) and (c>b) then writeln('b=',b,'a=',a) else
if (b>a) and (b>c) and (c>a) then writeln('a=',a,'b=',b) else
if (c>a) and (c>b) and (a>b) then writeln('b=',b,'c=',c) else
readln;
end

0,0(0 оценок)
Ответ:
Андріана1323
Андріана1323
12.06.2020 21:26

var 

  a, b, c: real;

 

begin

  writeln('Введите 3 любых числа');

  readln(a, b, c);

  if (a < b) and (a < c) then writeln(a, ' - наименьшее число');

  if (b < a) and (b < c) then writeln(b, ' - наименьшее число');

  if (c < a) and (c < b) then writeln(c, ' - наименьшее число');

  if (a > b) and (a > c) then writeln(a, ' - наибольшее число');

  if (b > a) and (b > c) then writeln(b, ' - наибольшее число');

  if (c > a) and (c > b) then writeln(c, ' - наибольшее число');

  readln; //Убрать если среда разработки не Turbo Pascal

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?