В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ivanbaclan
ivanbaclan
28.06.2022 09:22 •  Информатика

Язык паскаль, можно через while написать программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор пока не будет введён ноль) и подсчёт суммы введённых положительных чисел. используйте оператор repeat

Ответ:
Gelua2128
Gelua2128
12.06.2020 20:58

Объяснение:

Pascal

var a,i,s,n:integer;

begin

 s:=0;

 n:=0;

 repeat

    readln(a);

    if a>0 then begin

       n:=n+1;

       s:=s+a;

    end;

 until a = 0;

 writeln('Сумма ',s:5,'  Среднее арифметическое ',s/n);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?