В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Minimuux
Minimuux
08.07.2020 01:07 •  Информатика

Написать программу нахождения суммы и среднего арифметического значения элементов целочисленного массива размерностью n. С одномерного массива. n равен количеству 5
*размерность - количество элементов массива

Ответ:
chamk
chamk
05.01.2021 22:40

program z1;

const n=5;

var i,s: integer;

a:array[1..n] of integer;

begin

s := 0;

write('Массив : ');

for i:=1 to n do

begin

a[i]:=random(10);

write(a[i]:3);

s:=s+a[i]

end;

writeln;

writeln('Сумма значений элементов целочисленного массива ',s);

writeln('Среднее арифметическое значений элементов целочисленного массива ',s/n)

end.

Объяснение:

n - размерность массива

s - сумма значений элементов

В цикле с параметром:

1) задаём значение элемента массива

2) выводим элемент на экран

3) считаем сумму

Выводим на экран сумму

Выводим на экран среднее арифметическое (делим сумму на количество элементов массива)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?