В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alica123434
alica123434
19.08.2021 23:23 •  Информатика

Решить задачу: написать программу нахождения элемента массива равного 7. Вывести на экран номер этого элемента. Если такого элемента не встретится, то вывести сообщение "нет" Массив заполняется случайными числами от 1 до 50. Использовать цикл с постусловием(repeat...until).

Ответ:
pula04
pula04
05.01.2021 21:24

Проверку можно устроить, например, так. Пусть сначала i = 0, и в цикле увеличиваем i, пока не уйдем за границы массива или не встретим элемент, равный 7. После выхода из цикла проверяем, по какой причине был выход из цикла, и в зависимости от этого выводим либо номер элемента, либо сообщение об отсутствии семерок. При этом будет выведен только номер первой семерки, если их в массиве несколько.

Вывод массива можете дописать при необходимости самостоятельно, видимо, считается, что вы это умеете делать :)

Код (Pascal):

const

 n = 20;

var

 a: array[1..n] of integer;

 i: integer;

begin

 randomize;

 for i := 1 to n do

   a[i] := random(50) + 1;

 i := 0;

 repeat

   i := i + 1;

 until (i > n) or (a[i] = 7);

 if i > n then

   write('нет')

 else

   write(i)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?