В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
дома9
дома9
12.03.2022 21:53 •  Информатика

Напишите программу в C++: Найти сумму и количество целых чисел больших 20, меньших 200 и кратных 3. Вывести числа, удовлетворяющие условию, их количество, найденную сумму, среднее арифметическое. Вывести числа, заканчивающиеся на 0.

Ответ:
триggg
триggg
05.01.2021 20:04

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   float summa, count = 0;

   vector<int> result, zero;

   for (int i = 21; i < 200; i++)

   {

       if (i % 3 == 0)

       {

           result.push_back(i);

           count++;

           summa += i;

           if (i % 10 == 0)

           {

               zero.push_back(i);

           }

       }

   }

   cout << R"(Числа которые заканчиваютса нулем )" << endl;

   for (int i = 0; i < zero.size(); i++)

   {

       cout << zero[i] << ' ';

   }

   cout << endl;

   cout << R"(Числа которые кратные 3)" << endl;

   for (int i = 0; i < result.size(); i++)

   {

       cout << result[i] << ' ';

   }

   cout << endl;

   cout << R"(Количество таких чисел = )" << count << endl;

Дальше немного сами подумайте если я это написал и вы это не поняли. Советую учить С++. Потому что вы не будете понимать что вы делаете.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?